Error installing on 2 boxes

Jun 19, 2007 at 12:14 PM
Customer reported following when installing: Any help is appreciated.

Hello,

I am trying everything to get this to work. I am installing on a two machine setup. Step 1 went fine, but step two has problems. In the log file entries below for the Project Server Connector installation (part 2) I get an error and it stops. I have edited out the repeat entries. The first set is the error ending in "CreateLookupTable failed due to following Exception : System.Xml.XmlElement" but below that in set 2, I don't get that far anymore. I am following the instructions by the book and cannot figure out what I am doing wrong. I am running this all under the domain service account. If I could talk to a live person that would help. In step one, it found the GUID automatically so I didn't think it would be important enough to write down and it seems to be the problem in step 2. Of course I can't find the GUID for the life of me in spite of explicit instructions in the user instruction manual.

Logging started at: 06/18/07 12:34:46

< 12:34:46 >Start PS2007-TFS Connector Setup
< 12:34:46 >CheckIfInstallerRunning
< 12:34:46 >CopyFromMsi
< 12:35:51 >CheckConnectorNameIsValid
< 12:35:52 > CheckMachineNameIsValid Started
< 12:35:52 > CheckMachineNameIsValid Completed
< 12:36:12 >CheckServiceUserIsEmpty
< 12:36:12 > CheckEmptyString Started
< 12:36:12 > CheckEmptyString Completed
< 12:36:51 >CheckPSPWAUrlIsValid
< 12:36:51 > CheckUrlFormatIsValid Started
< 12:36:51 > CheckUrlFormatIsValid Completed
< 12:37:26 >PSEventHandlersInstall
< 12:37:26 > InstallPSEventHandlers Started
< 12:37:26 > GetUserCredentials started
< 12:37:26 > GetUserCredentials Completed
< 12:37:26 > Loging to the project server event service : http://dev-msi-vm06/PWA/vtibin/psi/events.asmx
< 12:37:26 > LoginToEventsService Started
< 12:37:28 > LoginToEventsService Completed
< 12:37:41 > Adding event data row.
< 12:37:41 > Creating eventhandler associations.
< 12:37:41 > InstallPSEventHandlers Completed
< 12:37:41 >CreateLookupTablesAndCustomFields
< 12:37:41 > InstallProjectServerFields Started
< 12:37:41 > GetUserCredentials started
< 12:37:41 > GetUserCredentials Completed
< 12:37:41 > Creating lookup tables in project server.
< 12:37:42 > CreateLookupTable Started
< 12:37:42 > GetLookupTableGuid Started
< 12:37:52 > GetLookupTableGuid failed due to following Exception : System.Xml.XmlElement
< 12:37:52 > CreateLookupTable failed due to following Exception : System.Xml.XmlElement

Logging started at: 06/18/07 14:44:06

< 14:44:06 >Start PS2007-TFS Connector Setup
< 14:44:06 >CheckIfInstallerRunning
< 14:44:06 >CopyFromMsi
< 14:44:32 >CheckConnectorNameIsValid
< 14:44:32 > CheckMachineNameIsValid Started
< 14:44:32 > CheckMachineNameIsValid Completed
< 14:44:49 >CheckServiceUserIsEmpty
< 14:44:49 > CheckEmptyString Started
< 14:44:49 > CheckEmptyString Completed
< 14:45:06 >CheckPSPWAUrlIsValid
< 14:45:06 > CheckUrlFormatIsValid Started
< 14:45:06 > CheckUrlFormatIsValid Completed
< 14:45:11 >PSEventHandlersInstall
< 14:45:11 > InstallPSEventHandlers Started
< 14:45:11 > GetUserCredentials started
< 14:45:11 > GetUserCredentials Completed
< 14:45:11 > Loging to the project server event service : http://dev-msi-vm06/PWA/vtibin/psi/events.asmx
< 14:45:11 > LoginToEventsService Started
< 14:45:13 > LoginToEventsService Completed
< 14:45:16 > Adding event data row.
< 14:45:17 > Creating eventhandler associations.
Coordinator
Jun 19, 2007 at 5:55 PM
Seems like you're having an issue accessing the Project Server lookup table information. I'll contact you offline to get your contact information and try to help you through this.
Lenny
Jul 11, 2007 at 11:54 AM
Hello,

I have the same problem, there is any solution for this problem?

Thank You,

Dan Ciovica
Jul 12, 2007 at 6:52 AM
Hello,

I have run the following sql:

-- ensure that auxiliary tables for lookup tables only have rows for real lookup tables. This will delete rows for wbs, linked custom fields, etc.
SELECT * FROM dbo.MSPLOOKUPTABLELANGUAGES WHERE LTUID NOT IN (SELECT LTUID FROM dbo.MSPLOOKUP_TABLES)
SELECT * FROM dbo.MSPLOOKUPTABLEMASKVALUES WHERE LTUID NOT IN (SELECT LTUID FROM dbo.MSPLOOKUPTABLES)
SELECT * FROM dbo.MSPLOOKUPTABLEMASKSTRUCTURES WHERE LTUID NOT IN (SELECT LTUID FROM dbo.MSPLOOKUPTABLES)
SELECT * FROM dbo.MSPLOOKUPTABLEVALUES WHERE LTUID NOT IN (SELECT LTUID FROM dbo.MSPLOOKUP_TABLES)
SELECT * FROM dbo.MSPLOOKUPTABLESTRUCTURES WHERE LTUID NOT IN (SELECT LTUID FROM dbo.MSPLOOKUP_TABLES)

I have found one entry on the first sql and I have deleted it and then I have tried again to install the project server component concluded with the same error in the end...

Logging started at: 07/12/07 09:24:33
< 09:24:33 >Start PS2007-TFS Connector Setup
< 09:24:33 >CheckIfInstallerRunning
< 09:24:33 >CopyFromMsi
< 09:24:51 >CheckConnectorNameIsValid
< 09:24:51 > CheckMachineNameIsValid Started
< 09:24:52 > CheckMachineNameIsValid Completed
< 09:25:03 >CheckServiceUserIsEmpty
< 09:25:03 > CheckEmptyString Started
< 09:25:03 > CheckEmptyString Completed
< 09:25:17 >CheckPSPWAUrlIsValid
< 09:25:17 > CheckUrlFormatIsValid Started
< 09:25:17 > CheckUrlFormatIsValid Completed
< 09:25:25 >PSEventHandlersInstall
< 09:25:25 > InstallPSEventHandlers Started
< 09:25:25 > GetUserCredentials started
< 09:25:25 > GetUserCredentials Completed
< 09:25:25 > Loging to the project server event service : http://virtualps2007/projectserver/vti_bin/psi/events.asmx
< 09:25:25 > LoginToEventsService Started
< 09:25:28 > LoginToEventsService Completed
< 09:25:31 > Adding event data row.
< 09:25:31 > Creating eventhandler associations.

But in the Event View I have found:

1.
Standard Information:PSI Entry Point: Events.CreateEventHandlerAssociations
Project User: SOFTBIZSB\TFSSERVICE
Correlation Id: d98a36f8-1f45-44b0-bd70-1d4364ba12a8
PWA Site URL: http://virtual_ps2007/projectserver
SSP Name: SharedServices
PSError: ServerEventHandlerDuplicateEntry (22010)
Error occurred with event handler registration. An event handler with the same name as the one you are trying to register is already associated with the event.

2.
Standard Information:PSI Entry Point: Events.CreateEventHandlerAssociations
Project User: SOFTBIZSB\TFSSERVICE
Correlation Id: d98a36f8-1f45-44b0-bd70-1d4364ba12a8
PWA Site URL: http://virtual_ps2007/projectserver
SSP Name: SharedServices
PSError: ServerEventHandlerDuplicateName (22012)
Error occurred with event handler registration. And event handler with the same friendly name has been registered with the event. Please provide a different, unique friendly name for the event handler association record.


Please tell me what is the problem and what can I do to fix it?
Coordinator
Jul 19, 2007 at 12:36 PM
dciovica,
Whn you installed iniitally, it got part of the way and then failed. Unfortunately, the installer for the Connector doesnt roll bakc the changes he has made to PS2007 when it fails. So you have event handlers there that is trying to install again. PS2007 doesnt lilke that.

So, you're going to need to go to PS2007 and uninstall the event handlers for Project: OnPublished, OnCheckIn, and OnDeleted and Statusing: OnApplied, OnApprovalStatusUpdated, and OnTaskCreated (if it exists). You should then be able to install successfully.


HTH,
Lenny
Jul 20, 2007 at 2:08 PM
Dear Lenny,

I did what you told me and I have the firts error:


Logging started at: 07/19/07 19:19:04

< 19:19:04 >Start PS2007-TFS Connector Setup

< 19:19:04 >CheckIfInstallerRunning

< 19:19:04 >CopyFromMsi

< 19:19:27 >CheckConnectorNameIsValid

< 19:19:27 > CheckMachineNameIsValid Started
< 19:19:27 > CheckMachineNameIsValid Completed
< 19:19:42 >CheckServiceUserIsEmpty

< 19:19:42 > CheckEmptyString Started
< 19:19:42 > CheckEmptyString Completed
< 19:19:55 >CheckPSPWAUrlIsValid

< 19:19:55 > CheckUrlFormatIsValid Started
< 19:19:55 > CheckUrlFormatIsValid Completed
< 19:20:00 >PSEventHandlersInstall

< 19:20:00 > InstallPSEventHandlers Started
< 19:20:00 > GetUserCredentials started
< 19:20:00 > GetUserCredentials Completed
< 19:20:00 > Loging to the project server event service : http://sb2007/projectserver/vtibin/psi/events.asmx
< 19:20:00 > LoginToEventsService Started
< 19:20:02 > LoginToEventsService Completed
< 19:20:03 > Adding event data row.
< 19:20:03 > Creating eventhandler associations.
< 19:20:04 > InstallPSEventHandlers Completed
< 19:20:04 >CreateLookupTablesAndCustomFields

< 19:20:04 > InstallProjectServerFields Started
< 19:20:04 > GetUserCredentials started
< 19:20:04 > GetUserCredentials Completed
< 19:20:04 > Creating lookup tables in project server.
< 19:20:04 > CreateLookupTable Started
< 19:20:05 > GetLookupTableGuid Started
< 19:20:09 > GetLookupTableGuid failed due to following Exception : System.Xml.XmlElement
< 19:20:09 > CreateLookupTable failed due to following Exception : System.Xml.XmlElement

But in the Event View I have found:

1.
SEP: Cannot create instance of the receiver class: Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=44e8b64f78b9532d, Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers.StatusingEventsReceiver Exception: Could not load file or assembly 'Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=44e8b64f78b9532d' or one of its dependencies. The system cannot find the file specified.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

2.
SEP: Cannot create instance of the receiver class: Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=44e8b64f78b9532d, Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers.ProjectEventsReceiver Exception: Could not load file or assembly 'Microsoft.Vsts.Ranger.Connector.PS2007EventHandlers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=44e8b64f78b9532d' or one of its dependencies. The system cannot find the file specified.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
3.
PSI Auth: SiteId a7872a50-4e7a-4122-a74b-30be0c999787 was not found in the ProjectSiteCollection for this SSP.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Please tell me what is the problem and what can I do to fix it?


lfenster wrote:
dciovica,
Whn you installed iniitally, it got part of the way and then failed. Unfortunately, the installer for the Connector doesnt roll bakc the changes he has made to PS2007 when it fails. So you have event handlers there that is trying to install again. PS2007 doesnt lilke that.

So, you're going to need to go to PS2007 and uninstall the event handlers for Project: OnPublished, OnCheckIn, and OnDeleted and Statusing: OnApplied, OnApprovalStatusUpdated, and OnTaskCreated (if it exists). You should then be able to install successfully.


HTH,
Lenny

Coordinator
Jul 26, 2007 at 2:06 AM
it seems like perhaps the PS Eventing Service still believes those event handlers exist. Can you stop and start the microsoft Project Service Eventing Service to see if it helps with the issues? If your issues still exist, we can take this offline and can try to help you in a more efficient way.

HTH,
Lenny