Connector for VS Orcas and PS 2007

Aug 27, 2007 at 3:09 PM
Hi, I have set up connector in my company with TFS 2005 and PS2007. I am interested how it would be possible to set up connector to work with TFS Orcas and PS2007?
Coordinator
Aug 28, 2007 at 6:42 PM
We think it should work just find because there have been very few changes to the WorkItemTracking other APIs that the connector uses. However, having said that, we havent formally tested it yet.
Sep 21, 2007 at 9:11 AM
Hi,
I am trying to set up connector to work with TFS Orcas.
I have tried to install TFS Connector component (this will be two box installation) and I have received the following error:

Product: Microsoft Project Server 2007 Connector -- Installation operation failed


In PS2007-TFSConnectorSetup.log I have following information:

Logging started at: 09/20/07 17:04:29
< 17:04:29 >Start PS2007-TFS Connector Setup
< 17:04:29 >CheckIfInstallerRunning
< 17:04:29 >CopyFromMsi
< 17:05:04 >CheckServiceUserIsEmpty
< 17:05:04 > CheckEmptyString Started
< 17:05:04 > CheckEmptyString Completed
< 17:05:07 >TFSComponentInstal

Only difference between previous succesfull and current installation is that instead of TFS 2005 I have TFS Orcas.
Is there any solution for this problem? Thank You in advance.
Coordinator
Sep 22, 2007 at 1:07 PM

I havent tested that yet. However, the only thing the connector installs for TFS is a customized template which is completely optional (and most folks dont use anyway) and it sets up a subscription using bissubscribe. My guess is that it is the uploading of the custom template that is causing the installation issue. I'll see if I can get a TFS 2008 box to test this theory out.
Sep 24, 2007 at 7:56 AM
Hi,
We have solved this problem by manually setting the subscription to TFS events using bissubscribe. After this we had another problem with Orcas : it seems like it cannot return right templateid from method GetProjectProperties in CommonStructureService class. Return value is always -1 which causes exception throwing from connector web service.
We temporarily solved this by hard coding the templateid to 2 which is our default template and, for now, connector is working with TFS Orcas but this is not a good solution(or solution at all :)).
Best regards
Coordinator
Feb 4, 2008 at 6:18 PM
I am working on this. Hope to have this resolved within the next few weeks.
Thanks,
Lenny