Changes in TFS Work Item do not Reflect Back to PS

Nov 2, 2007 at 4:18 PM
Hi,

My scenario is when I complete a work item in TFS it does not go to Pending Tasks queue. I checked the Event Log and message is "This service was the last to change the WorkItem; therefore, change will be ignored"

Do you have any idea what is happening.

Thanks,
Hammad
Coordinator
Feb 4, 2008 at 6:22 PM
Yup.
There are a few checks that occur which filter out whether a WorkItem's changes should be propagated to Project Server. The very first check is whether the Connector was the one to update the WorkItem. This is done to avoid an endless loop where a change occurs in Project Server which causes a change in TFS which would then go back to the Connector as a change for Project Server again.

You're getting this message because you're running under the same Identity that you have configured the Connector to sun as. Thus, the Connector thinks it was the last one to update the WorkItem and filters it out.

HTH,
Lenny
Jan 21, 2009 at 5:38 AM
Edited Jan 21, 2009 at 5:38 AM
Hi Ifenster,

I'm struggling with this problem as well.
But I have no idea about "you're running under the same Identity that you have configured the Connector to sun as".
Would you please provide more specific?
Thanks,
Howard
Feb 19, 2009 at 10:11 AM
 Dear Sir
            I have installed TFS server 2005 at one machine and I have MS Project Server 2007 another machine. Now I want to connect Project server with TFS. I got the one link (http://www.codeplex.com/pstfsconnector/Wiki/View.aspx?title=Setup%20Guide), here I got the VSTS connector for MS Project Server 2007 and TFS 2005 integration. TFS2005 software is working very well before this connectore installation. When I installed the connector by following the proper guideline which are present at given link. After complete installation, When I start the TFS Server and open the TFS Explorer then I got following error.

"TFS31001: Team Foundation cannot retrieve the list of team projects from Team Foundation Server ss01-cpu-118. The TEam Foundation Server returned the following error: The request failed with HTTP status 404:."

I was installing this connector on TFS Machine as per guideline which are given on website(http://www.codeplex.com/pstfsconnector/Wiki/View.aspx?title=Setup%20Guide). I was login with TFSSETUP on TFS machine. Although I have installed TFS server 2005 with this Login. While on installation I used the TFSSERVICE account for TFS installation.

Please if any one have any solution about this problem. Please let me know ASAP.


Thanks

Best Regards

Muhammad Waseem Alvi