Team Foundation Server installation components error.

Mar 27, 2008 at 4:51 PM
Hi,

I try to install the Connector. There are exception when I install the third part of all installation (Team Foundation Server installation components).
The first 2 parts of the Connector were installed at the same computer with Project Server 2007. The Team Foundation Server 2008 installed at another computer.

Log text:
Logging started at: 03/27/08 17:48:13

< 17:48:13 >Start PS2007-TFS Connector Setup

< 17:48:13 >CheckIfInstallerRunning

< 17:48:13 >CopyFromMsi

< 17:48:49 >CheckServiceUserIsEmpty

< 17:48:49 > CheckEmptyString Started
< 17:48:49 > CheckEmptyString Completed
< 17:48:51 >CheckServiceUserIsEmpty

< 17:48:51 > CheckEmptyString Started
< 17:48:51 > CheckEmptyString Completed
< 17:48:55 >TFSComponentInstall

< 17:48:55 > InstallTfsComponent Started
< 17:48:56 > GetUserCredentials started
< 17:48:56 > GetUserCredentials Completed
< 17:48:56 > Authenticating with UserName : (server)\administrator
< 17:48:57 > InstallTfsComponent failed due to following exception : TF30076: The server name (server) provided does not correspond to a server URI that can be found. Confirm that the server name is correct.
Stacktrace for the exception : at Microsoft.TeamFoundation.Client.TeamFoundationServer.GetUriForName(String name)
at Microsoft.TeamFoundation.Client.TeamFoundationServer.get_Uri()
at Microsoft.TeamFoundation.Client.CheckAuthenticationProxy..ctor(TeamFoundationServer server)
at Microsoft.TeamFoundation.Client.TeamFoundationServer.Authenticate(Boolean useProvider, ICredentialsProvider provider)
at Microsoft.TeamFoundation.Client.TeamFoundationServer.Authenticate()
at CustomAction.CommonCustomAction.InstallTfsComponent(String connectorUrl, String userName, String password)
< 17:48:57 > InstallTfsComponent Completed

Thanks.
Coordinator
Mar 27, 2008 at 6:40 PM
You may need to have TE 2008 installed to get the TFS part to install properly. Please try that out.
Thanks,
Lenny
Mar 28, 2008 at 10:38 AM
I've installed TE 2008 before The Connector installation.

Thanks,
Sergey
Coordinator
Mar 28, 2008 at 3:28 PM
Is it working for you now?
Mar 31, 2008 at 8:56 AM
No, it isn't. Threre are the same exception. The exception arises when the TFS templates are installing.
Coordinator
Mar 31, 2008 at 1:09 PM
I see you are getting " InstallTfsComponent failed due to following exception : TF30076: The server name (server) provided does not correspond to a server URI that can be found. Confirm that the server name is correct.". what is the Uri for the servername that you are putting in? Have you verified that it exists at that URI?
Mar 31, 2008 at 4:40 PM
The servername is the name of my computer in network.
Coordinator
Apr 2, 2008 at 9:20 AM
Yes, but have you verified that you can connect to it properly , say with Team Explorer?
Sep 4, 2008 at 4:07 PM
I had the same error even after I installed TE 2008 as a fix for another problem (see http://www.codeplex.com/pstfsconnector/Thread/View.aspx?ThreadId=22667)
I then loaded Visual Studio 2009 which has been installed as a part of TE2008 installation (shell) and used Team Explorer to connect to my TFS 2005 Server.
This has succeeded.
I then ran installer again and it worked fine this time.