Project and Assignment Association Problems

May 12, 2008 at 1:10 PM
Edited May 12, 2008 at 1:12 PM

I have some problems with project associations. I can create project association trough Connector web site, but it remains locked. In event viewer I get two errors (attached). It looks like assembly 'Microsoft.Vsts.Ranger.Connector.PS2007Providers' is missing, but Connector web service works, at least unlocking the project and listing projects work ok from browser. Assembly is present in web services bin folder.

If I manualy unlock project association, and then try to create new assignment association trough Connector web site, I can see work items (in WorkItem drop down), but no tasks. It appears that something is wrong with Project Server connection, because I cannot see any tasks from project. How can I check out if project connection is setup properly?


Event Type:       Error

Event Source:   ASP.NET 2.0.50727.0

Event Category:               None

Event ID:             1334

Date:                    12.5.2008

Time:                    12:49:08

User:                    N/A

Computer:         SERVER

Description:

An unhandled exception occurred and the process was terminated.

 

Application ID: DefaultDomain

 

Process ID: 4544

 

Exception: System.Runtime.Serialization.SerializationException

 

Message: Unable to find assembly 'Microsoft.Vsts.Ranger.Connector.PS2007Providers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null'.

 

StackTrace:    at System.Runtime.Serialization.Formatters.Binary.BinaryAssemblyInfo.GetAssembly()

   at System.Runtime.Serialization.Formatters.Binary.ObjectReader.GetType(BinaryAssemblyInfo assemblyInfo, String name)

   at System.Runtime.Serialization.Formatters.Binary.ObjectMap..ctor(String objectName, String[] memberNames, BinaryTypeEnum[] binaryTypeEnumA, Object[] typeInformationA, Int32[] memberAssemIds, ObjectReader objectReader, Int32 objectId, BinaryAssemblyInfo assemblyInfo, SizedArray assemIdToAssemblyTable)

   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadObjectWithMapTyped(BinaryObjectWithMapTyped record)

   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadObjectWithMapTyped(BinaryHeaderEnum binaryHeaderEnum)

   at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.Run()

   at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)

   at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)

   at System.Runtime.Remoting.Channels.CrossAppDomainSerializer.DeserializeObject(MemoryStream stm)

   at System.AppDomain.Deserialize(Byte[] blob)

   at System.AppDomain.UnmarshalObject(Byte[] blob)

 


 

Event Type:       Error

Event Source:   .NET Runtime 2.0 Error Reporting

Event Category:               None

Event ID:             5000

Date:                    12.5.2008

Time:                    12:49:12

User:                    N/A

Computer:         SERVER

Description:

EventType clr20r3, P1 w3wp.exe, P2 6.0.3790.3959, P3 45d6968e, P4 mscorlib, P5 2.0.0.0, P6 471ebc5b, P7 4642, P8 4b, P9 150kuqa02kududulzcxaalj5gspipj25, P10 NIL.


Coordinator
May 12, 2008 at 2:56 PM
This error is usually the result of something else going wrong.  Do you see any other errors occurring prior to these in the event log?
May 13, 2008 at 8:07 AM
Edited May 13, 2008 at 9:05 AM
I created new project association with no options for task linking set. Association between projects looks ok, lock is not applied. When I try to add assignment association, I get disabled drop down list for tasks. If I switch to "By Assignment" view, I can see project tasks, but now work items get disabled.

There's no errors or warnings in event log, just a few Enterprise Library Logging infos and Office SharePoint Server infos. Two recurring infos, probably not connected to my problem, contain the following:

1) Provisioning database SP-SV.ProjectServer_Reporting MUI files for Reporting database type for 1060 lcid.
2) Failed to provision database SP-SV.ProjectServer_Reporting MUI files for Reporting database type for 1060 lcid directory D:\Program Files\Microsoft Office Servers\12.0\Sql\Project Server\Core\ or D:\Program Files\Microsoft Office Servers\12.0\Sql\Project Server\Core\1060 don't exist.
May 13, 2008 at 4:34 PM
I have a similar problem. Installation went fine and I can create a association for projects. But it seems not to associate items. If I try to do thi manualle I have a empty and disabled Task DDL (By Workitem) or a empty and disabled WorkItem DDL (By Assignment).

I get no errors in the event log.
May 13, 2008 at 8:06 PM
I solved my problem. It seems the Project didn't store the WorkitemType well. When I repoened the project to check this, they were empty. So I reentered them and now I am able to enter associations´,