WorkItem Association Problem

Sep 4, 2008 at 9:41 PM

I think that I'm having the same problem several others are having.  I've installed the connector on a two server configuration and everything seems to be going well.  I've created a new project, added several tasks, set the enterprise task type for each task and published the project back to the server.  I then updated my project template (following the instructions from the blog referenced on the releases page) and created a project in TFS.  I was then able to go and create a project association.  So far so good...

I've now run into two problems:

1)  I can't create an assignment association because my task dropdown list is empty when work items are selected and vice versa
2)  I can only access the connector from the computer that the web site is installed on - I think this related to kerberos, but I'm not sure... any hints?

I've seen numerous posts regarding #1, but none of the solutions seem to be my problem.  I don't get any event errors and my project has the correct enterprise type selected (in this case, task).

The only events I receive are on my project server.  I'm getting what looks like 401 errors for my Project Server web services.  How do I give additional people access to these services?

Thanks!

Sep 4, 2008 at 10:13 PM
Ok, I've made it a bit further.. If I associate a project file with a tfs project with a built-in template (such as the CMMI template) it works correctly and I get my tasks back.  I noticed that the web.config for the connector web services has entries for the agile and CMMI process templates.  Do I need to add an entry for my custom process template?
Sep 4, 2008 at 11:54 PM
I think you have to add one entry for each template that you want to use. When I added the Agile for PS connector the the web.config, I started to see the tasks.
Sep 5, 2008 at 1:21 PM
Thanks, Robby - I'll try that and post how it goes.  One quick additional question - which site GUID should be in the web.config for the connector services?  Should it be the GUID for the PWA site or the shared services site?
Sep 5, 2008 at 1:36 PM
That worked!  I now see tasks listed and can create assignment associations (sort of).  I've gotten to the point where I can click the 'Add' button and the task/assignment mapping appears.  However, when I click the submit button, the project just becomes locked and stays that way.
Sep 7, 2008 at 11:49 PM
Check the event log of the connector machine.

About the GUID, see in the FAQ here (I am receiving a 401 error when I try to use the Connector Web Site. What is wrong?)

Cheers ;-)
Sep 9, 2008 at 3:14 PM
Edited Sep 9, 2008 at 4:28 PM
I checked with the FAQ and it looks like the site guid should be the SSP site guid.  The Setup guide should probably be changed because (I think) it has you pick the site guid of the PWA site.

The error I'm getting is:
The work item cannot be saved because the following fields are invalid: State(Proposed)

I haven't modified the possible states of the work items and none of them have the state of Proposed

----

Fixed this... it was a problem with my web.config.  My custom template did not have the state proposed available and the web.config mappings for the connector services specified that it did.  I went back and switched it back to the agile process.

However, I'm now getting the errors in the connection server event log:
"Server was unable to process request -> Object reference not set to an instance of an object"
followed by
"Unable to create new assignments"

What's strange is that it did assign the TFS work item as necessary, so some of the operation worked
Sep 9, 2008 at 11:34 PM
But it is the guid of the pwa site... the faq says:

  • Hover over your PWA site so that the dropdownselection appears and click edit
  • In the address bar, you should see a Guid at the end of the URL. This is the SiteGuid. Make sure it is the same as what is in the web.config file.

    For that null object reference, I don't know how to help you...I got the same error on one of my tries and I haven't solved it yet :-(

    If you solve it, please let me know ^^